Discussion:
Official PPA for dmd
(too old to reply)
Andrew Pennebaker via Digitalmars-d
2014-08-01 19:34:11 UTC
Permalink
I'm happy to see an official .DEB for installing DMD! Could we
please host this in a PPA, to make it easier for Debian/Ubuntu
users to install?

This would make dmd play nicer with automated provisioning sytems
like Chef/Puppet, and pave the way for dmd making it into the
official Ubuntu repositories one day.
Brad Anderson via Digitalmars-d
2014-08-01 19:36:45 UTC
Permalink
Post by Andrew Pennebaker via Digitalmars-d
I'm happy to see an official .DEB for installing DMD! Could we
please host this in a PPA, to make it easier for Debian/Ubuntu
users to install?
This would make dmd play nicer with automated provisioning
sytems like Chef/Puppet, and pave the way for dmd making it
into the official Ubuntu repositories one day.
It's not a PPA but Jordi's D-apt is useful.

http://d-apt.sourceforge.net/
Andrew Pennebaker via Digitalmars-d
2014-08-01 19:58:56 UTC
Permalink
Yes it is, thank you!


...could we turn that into a full PPA?


On Fri, Aug 1, 2014 at 2:36 PM, Brad Anderson via Digitalmars-d <
Post by Brad Anderson via Digitalmars-d
I'm happy to see an official .DEB for installing DMD! Could we please
host this in a PPA, to make it easier for Debian/Ubuntu users to install?
This would make dmd play nicer with automated provisioning sytems like
Chef/Puppet, and pave the way for dmd making it into the official Ubuntu
repositories one day.
It's not a PPA but Jordi's D-apt is useful.
http://d-apt.sourceforge.net/
--
Cheers,

Andrew Pennebaker
www.yellosoft.us
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puremagic.com/pipermail/digitalmars-d/attachments/20140801/8e398642/attachment.html>
Russel Winder via Digitalmars-d
2014-08-02 09:56:59 UTC
Permalink
On Fri, 2014-08-01 at 14:58 -0500, Andrew Pennebaker via Digitalmars-d
Post by Andrew Pennebaker via Digitalmars-d
Yes it is, thank you!
...could we turn that into a full PPA?
On Fri, Aug 1, 2014 at 2:36 PM, Brad Anderson via Digitalmars-d <
[
]
Post by Andrew Pennebaker via Digitalmars-d
Post by Brad Anderson via Digitalmars-d
It's not a PPA but Jordi's D-apt is useful.
http://d-apt.sourceforge.net/
What does a PPA provide that D-apt doesn't? D-apt is a line in my
sources.list file (*) and aptitude (**) works fine with it for all
updates provided by "the system".


(*) for approx reasons I do not use the sources.list.d stuff.

(**) apt-get is second rate compared to aptitude.
--
Russel.
=============================================================================
Dr Russel Winder t: +44 20 7585 2200 voip: sip:russel.winder at ekiga.net
41 Buckmaster Road m: +44 7770 465 077 xmpp: russel at winder.org.uk
London SW11 1EN, UK w: www.russel.org.uk skype: russel_winder
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: This is a digitally signed message part
URL: <http://lists.puremagic.com/pipermail/digitalmars-d/attachments/20140802/df68eef9/attachment.sig>
bachmeier via Digitalmars-d
2014-08-01 22:14:35 UTC
Permalink
On Friday, 1 August 2014 at 19:59:06 UTC, Andrew Pennebaker via
Post by Andrew Pennebaker via Digitalmars-d
Yes it is, thank you!
...could we turn that into a full PPA?
Thanks for volunteering.

I prefer the current system. It is easier than configuring a PPA
and the .deb packages are official if you download them from
dlang.org. I don't easily trust a PPA. It's also not the kind of
upgrade I want to happen automatically.
Andrew Pennebaker via Digitalmars-d
2014-08-01 22:46:49 UTC
Permalink
You don't have to use ppa's, but many Deb/untu users like them.
On Aug 1, 2014 5:15 PM, "bachmeier via Digitalmars-d" <
Post by bachmeier via Digitalmars-d
On Friday, 1 August 2014 at 19:59:06 UTC, Andrew Pennebaker via
Post by Andrew Pennebaker via Digitalmars-d
Yes it is, thank you!
...could we turn that into a full PPA?
Thanks for volunteering.
I prefer the current system. It is easier than configuring a PPA and the
.deb packages are official if you download them from dlang.org. I don't
easily trust a PPA. It's also not the kind of upgrade I want to happen
automatically.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puremagic.com/pipermail/digitalmars-d/attachments/20140801/b1619d91/attachment.html>
Jordi Sayol via Digitalmars-d
2014-08-03 09:35:17 UTC
Permalink
I'm happy to see an official .DEB for installing DMD! Could we please host this in a PPA, to make it easier for Debian/Ubuntu users to install?
dmd backend license is not compatible with PPA.
--
Jordi Sayol
Andrew Pennebaker via Digitalmars-d
2014-08-03 15:58:27 UTC
Permalink
That's unfortunate. Anyone know why?


On Sun, Aug 3, 2014 at 4:35 AM, Jordi Sayol via Digitalmars-d <
I'm happy to see an official .DEB for installing DMD! Could we please
host this in a PPA, to make it easier for Debian/Ubuntu users to install?
dmd backend license is not compatible with PPA.
--
Jordi Sayol
--
Cheers,

Andrew Pennebaker
www.yellosoft.us
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puremagic.com/pipermail/digitalmars-d/attachments/20140803/e472779f/attachment-0001.html>
eles via Digitalmars-d
2014-09-03 08:47:19 UTC
Permalink
On Sunday, 3 August 2014 at 09:47:56 UTC, Jordi Sayol via
El 01/08/14 21:34, Andrew Pennebaker via Digitalmars-d ha
Post by Andrew Pennebaker via Digitalmars-d
I'm happy to see an official .DEB for installing DMD! Could we
please host this in a PPA, to make it easier for Debian/Ubuntu
users to install?
dmd backend license is not compatible with PPA.
Hello,

Could a package for dvm be added to d-apt repository? It is
simple, but will allow automatic updates with everything else
that is D-related.

See this message:

http://forum.dlang.org/post/lu6bcg$306u$1 at digitalmars.com

Thanks.

PS Is it me, or dmd-bin is not yet upgraded to 2.066?
Jordi Sayol via Digitalmars-d
2014-09-03 09:46:25 UTC
Permalink
Could a package for dvm be added to d-apt repository? It is simple, but will allow automatic updates with everything else that is D-related.
Ok, I'll create new deb package for dvm.

Should this package be incompatible with dmd-bin?
PS Is it me, or dmd-bin is not yet upgraded to 2.066?
Yes, that's correct. I juts wait for next dmd v2.067 to avoid all the 2.066 regressions.
--
Jordi Sayol
eles via Digitalmars-d
2014-09-03 18:17:12 UTC
Permalink
On Wednesday, 3 September 2014 at 18:08:17 UTC, Jordi Sayol via
Post by Jordi Sayol via Digitalmars-d
Post by eles via Digitalmars-d
Could a package for dvm be added to d-apt repository? It is
simple, but will allow automatic updates with everything else
that is D-related.
Ok, I'll create new deb package for dvm.
excelent. Thanks.
Post by Jordi Sayol via Digitalmars-d
Should this package be incompatible with dmd-bin?
no. They are orthogonal
Post by Jordi Sayol via Digitalmars-d
Post by eles via Digitalmars-d
PS Is it me, or dmd-bin is not yet upgraded to 2.066?
Yes, that's correct. I juts wait for next dmd v2.067 to avoid
all the 2.066 regressions.
Very wise. Unfortunate, but 2.066 is bad...
eles via Digitalmars-d
2014-10-15 07:21:16 UTC
Permalink
On Wednesday, 3 September 2014 at 18:08:17 UTC, Jordi Sayol via
Post by Jordi Sayol via Digitalmars-d
Yes, that's correct. I juts wait for next dmd v2.067 to avoid
all the 2.066 regressions.
Maybe this worths the pain?...

http://forum.dlang.org/post/543dd28193525_57e33ffa705592b89923 at hookshot-fe3-cp1-prd.iad.github.net.mail

2.067 is quite far ahead...

Thanks

Continue reading on narkive:
Loading...